
The following changelog reflects all changes since the release v0.9.

Version 1.1.0
Added

 Enhanced sampling optimization for devices with builtin arbitrary function. Users can 
switch back to old sampling optimization behavior (called "legacy" now) via preferences

 Git commit hash will be printed to log file and can be shown in About dialog by clicking on 
the version number

 Updated waveform library to include all test cases of ISO 16750-2:2023

 Updated waveform library to include all test cases of ISO 21780:2020

Changed

 The log file will be written to %LocalAppData%\Toellner\WaveControl\Wave
Control.log as default, no external configuration via log.properties file is required

Fixed

 Preview of imported CSV data does not take Windows display scaling settings into account

 DAQ card initialization fails when using DAQmx version 24 and newer

 Runtime error 216 on shutdown if initialization of a DAQ card failed

 WaveControl might miss DC parts of the waveform when optimizing the waveform data for 
devices with built-in arbitrary function

 Maximum file size of log file isn't respected and log file backup doesn't work

 Errors occurring during license processing might not get handled properly

 WaveControl crashes on startup if another instance is already running and the log file has 
reached its maximum size

 Rare integer overflow errors during waveform playback

 Accessing the same GPIB devices in parallel from multiple instances of WaveControl inter-
feres with device communication

 Enhanced error handling in case of locked GPIB devices

Security

 Large license files (2GB in size) will cause WaveControl to crash, leading to a DoS attack 
surface

Version 1.0.0a
Added

 Updated waveform library to include ISO 16750-2:2023 test case 4.4: superimposed alter-
nating voltage

Version 1.0.0
Added

 Support for TOE 8872-42 and TOE 8872-44

 Manually select the display language of WaveControl via "Help" -> "Language"



 Log messages to indicate problems with firmware version and/or missing device options 
during device search

 Extended support for other devices

Changed

 WaveControl version will be displayed in status area of the remote control window at all 
times

Fixed

Waveform rendering does not take Windows display scaling settings into account

Version 0.9.14

Fixed

 Uploading waveform data to devices with internal arbitrary function fails with an index out 
of bounds exception

Version 0.9.13
Added

 Multiple segments might be selected using Ctrl+Click or Shift+Click in table view 
(same behavior as in plot view)

Changed

 Table view and plot view scroll to the current selection on selection changes

 Menu items Edit → Paste → Paste at end and Edit → Paste → Replace current selection 
have been merged into Edit → Paste → Paste/Replace. The menu item will either paste at 
the end or replace the current selection if available. This improves consistence of the item's 
behavior across waveform editing and text input field editing

Fixed

 Importing CSV files and/or connecting to DAQ cards causes non-recoverable access viola-
tions

 Opening waveform documents containing hundreds or even more segments takes several 
minutes (at least)

 Some required DAQ card properties aren't setup properly, errors with the configuration will 
be detected late (at playback start)

 WaveControl might destroy opened document files on crash

 Selecting waveform segments in plot view does not select the segments in table view

 Changing waveform color does not update plot view

 Display set values for start value and end value of a segment instead of recalculated values 
in table view

 Empty or invalid waveform names cause unnecessary noise during document load

 The input field for waveform renaming might cause UI glitches

 Del, Ctrl+X, Ctrl+C, Ctrl+V shortcuts don't work within text input fields



 Cut, Copy, Paste, and closing a document leak memory

Version 0.9.12

Added

 Open WaveControl's log file from the help menu: Select Help -> Open log file to open 
the log file in your default text editor

 Disconnect without device reset: Select Only disconnect from the new disconnect drop-
down menu in Remote dialog

 Set default behavior of the disconnect button and DAQ sample rate limit on the Device 
control page of WaveControl's preferences

Changed

 Use toeusb.dll instead of legacy toedrv32.dll if available

Fixed

 WaveControl has to be restarted when playing multiple waveforms via DAQ card

 Check existence of driver libraries before loading them

 Always resolve relative log file path names from WaveControl's config directory

 Wrong settings recommendations for TOE 9261 in Device Wizard

 Inconsistencies in UI texts and translations

 Performance regressions when updating preview on CSV import

 Import of CSV data fails with error "Floating point overflow" when time steps
are read from CSV file

 Agilent/Keysight CSV import template fails to detect correct start line in
some cases

 Access violation when importing multiple waveforms at once into a reverted

 empty document

 The text cursor in spin boxes might get hidden behind the spin control

Version 0.9.11
Added

 Include Windows version, installation directory, config file name and log config file name in 
log file at startup

Fixed

 WaveControl recommends 100 kHz bandwidth for TOE 7620 in CC mode (but this setting 
is not supported by the device)

 Saving start and end values of interpolations might be inaccurate and cause drift of the val-
ues on loading waveform files

 Exponential and logarithmic interpolation do not behave as expected

 WaveControl detects clipping although no clipping is going to happen

 Non-chronological timestamps create segments with negative duration on CSV import



Version 0.9.10
Added

 Remote dialog displays elapsed or remaining time during waveform playback 

 Create a log file for debugging purposes (see below for details) 

 Allow limiting sample rate of DAQ cards (see below for instructions) 

Changed

 Device connection wizard will remember the last settings for connected device, trigger, etc. 

Fixed

 Long running waveform playbacks (typ. longer than 1503 s) fail on DAQ cards with error 
-200077 

 TOE 8870 executes step 1 after waveform playback has finished 

 GPIB controllers that have been connected to the system after WaveControl has been started 
will not show up on device search 

 Output does not get enabled when using a DAQ card for analog control of TOE 8800 or 
TOE 8870 

 Various other bugs and performance issues 

Additional Notes

Log File Support

WaveControl creates a log file (WaveControl.log) that contains information on WaveControl's 

interaction with the connected devices. The log file is a normal text file that can be opened by dou-
ble clicking it in Explorer.

The location of the log file varies across different versions of Windows:

 Windows 8.1 and below 
The log file will be put in the installation directory of WaveControl (where WaveCon-
trol.exe resides). Typically this is C:\Program Files 
(x86)\Toellner\WaveControl. 

 Windows 10 
The log file will be put in a special directory created by Windows in the users Local App 
Data directory (typically C:\Users\<insert your username 
here>\AppData\Local\VirtualStore\Program Files 
(x86)\Toellner\WaveControl). The directory can be opened in Explorer by enter-

ing the following path into the navigation bar: %LocalAppData%
\VirtualStore\Program Files (x86)\Toellner\WaveControl. 

The log file should be sent to Toellner in case an error occurred within WaveControl.

Limiting Sample Rate of DAQ Cards

If you experience error -200621 (onboard device memory underflow) when using a DAQ card for 
waveform generation it might help to reduce the sample rate used by WaveControl for the DAQ 
card. Open the file C:\Users\<insert your username 



here>\AppData\Roaming\Toellner\WaveControl\Designer\WaveCon-
trol.ini in a text editor (you can use Windows' default Notepad). The directory AppData is 

hidden by default. To access the directory of WaveControl.ini enter the following path into 

the navigation bar of an Explorer window: %AppData%\Toellner\WaveControl\De-
signer.

After you have opened the file in your favorite text editor (you can double click it in Explorer), ap-
pend the following two lines at the bottom of the file:

[DAQmx]
SampleRateLimit=100000

This will limit the sample rate used to a maximum of 100 kSamples/s. If you require higher sample 
rates adjust the value to your needs. Please note that higher sample rates are more likely to fail 
again.

Version 0.9.8
Added

 Support for TOE 7621-80-60 (TOE 7621-80 limited to 60 V)

 Choose interpolation mode (Sample-and-Hold or Linear) when importing CSV files

 Remember last settings for connected device, number of parallel connected devices, output 
enable state, and trigger settings for every device

Changed

 Triggering DAQ cards is now possible on PFI channels

Fixed

 More possible race conditions when playing back waveforms on DAQ cards (especially 
slower cards)

 The maximum burst that can be entered in remote dialog is 255 for all devices, regardless of 
the real maximum burst value supported by the device

 Recommended hardware settings for TOE 9260 and TOE 9261 are not shown when con-
necting

 Various translation issues in remote dialog

Version 0.9.7
Fixed

 Race conditions when playing back waveforms on slow DAQ cards

 "Access denied" and "Invalid handle" error messages after standby, lock screen or screen-
saver



Version 0.9.6
Fixed

 Waveforms are not executed from the beginning if waveform execution is restarted on DAQ 
cards

 Phase of saw-tooth signals is rotated by 180 degrees

 Fixed some memory leaks

 Fixed various issues regarding the UI

Version 0.9.5
Fixed

 In case of errors while executing waveforms on DAQ the remote dialog does not show an 
error but just sits and waits for the execution to resume

Version 0.9.4
Added

 Import of CSV files: Go to "File→Import"

 Display license type and state on license dialog

Fixed

 Number of parallel connected TOE 7621 can be changed. This is required when operating as 
current source (CC mode)

 Fixed various issues regarding the UI

Version 0.9.3
Added

 Support for TOE 7621 as current source (CC mode)

 Press `Esc` to cancel editing in table view

Fixed

 No GPIB and no DAQ devices are found if either GPIB driver or DAQ driver is not in-
stalled

 Fixed various issues regarding the UI

Version 0.9.2
Fixed

 TOE 8950 devices with firmware version < 2.5 will restart when uploading waveforms

 Sampling for TOE devices produces wrong value of DC segments at the end of waveforms



Version 0.9.1
Fixed

 Waveform names are not checked for validity when opening a document from disk

 Phase value of superpositions must be treated as degrees when reading or writing waveform 
documents

 Fixed various issues regarding the UI

Version 0.9
Added

 Support for bipolar waveforms

 Support for dual channel devices

 'Cut', 'Copy', 'Paste' and 'Delete' for segments

 You can now add more than one waveform of each type

 Segments can have more than two superpositions. Superpositions are always additive

Changed

 The 'About' box displays information about used third party components

 Improved device search

 Improved user experience when connecting to a device

 %APPDATA%\Toellner\WaveControl\Designer\WaveControl.cfg is not used any longer 
and can be removed

Fixed

 Frequencies smaller than 1mHz could not be entered

 Frequency sweeps are not reproduced correctly

 Waveforms exceeding the device boundaries lead to invalid values when trying to execute 
the waveform via DAQ

 The square wave superposition does not support a frequency or duty cycle of 0

 Sequence mode will not be disabled when disconnecting from TOE 8870

 Fixed various issues regarding the UI
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